Thursday, September 25, 2014

Restart CREATE_TEMP_TABLE won’t work

Whilst I was running the database setup of a brand new FSCM 92 Peopletools 8.54 database, the server has all of sudden crashed down.
Once restarted, checking the logs files produced by the DMS script, I was able to determine the step it was doing when it stopped. It was the very last step, CREATE_TEMP_TABLE.
Here’s the beginning of that log :
Since the server crashed without notice, it ends in the middle of nowhere and without error. There is nothing much about restarted this step in the Peopletools installation guide, I thought restart would simply work straight away…

And here start the troubles :
As you may see, the command restarts from the beginning. But it dramatically failed on a table it was successful at the first place.
The guilty here is the table PSPTMATVWDEP which does not exists. What ?
Indeed, it does not.
And now what ? Looking at all the logs files of load (epengs.log, epengl.log…), that table is “missing”.

I found a very old note on MOS – actually from 2010 !, “How can you restart Data Mover for the CREATE_TEMP_TABLE command (Doc ID 660214.1)”. It is clearly mentioned that CREATE_TEMP_TABLE cannot be restarted. If it fails for some reason, two ways :
1. if you don’t have to upgrade your database to the latest Peopletools release, open AppDesigner, create a new project, insert all the temp tables (or from the first it failed on till the end, cf log file) and build.
You should see something like this :

2. if you have to update your database to the latest Peopletools release, then continue (Task 7-2: Updating Database to Latest PeopleTools Release) and run what described above afterwards.
Just for info, that table PSPTMATVWDEP is created in rel854xx :

It was new to me. Never late for learning…

Should I say that whether table is mandatory, it is empty ? Also empty on image FSCM92008… Hmmm.



No comments: